Indigenous Peoples' Day
Incident Report for Interseller
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 08:37 EDT
Identified
The Interseller team will be off on, Monday, October 12, 2020, in observance of Indigenous Peoples' Day. Our team will return the following day, Tuesday October 13, 2020 at 9am EST.

Because Indigenous Peoples' Day is a national U.S. holiday, your emails may be paused due to a setting in your schedule. To turn this off, head over to https://app.interseller.io/settings/schedule and turn off "Exclude U.S. Holidays" to have emails continue sending.
Posted Oct 11, 2020 - 23:01 EDT
This incident affected: Support & Live Chat (Support Team).