Issues with Exchange accounts
Incident Report for Interseller
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 17:04 EST
Identified
Nylas, our email syncing provider, is currently having issues authenticating with Hosted Exchange accounts. We are currently working with them to resolve the problem.

This does not affect Gmail or Outlook 365 accounts.
Posted Feb 23, 2021 - 08:49 EST
This incident affected: Email Sending & Syncing.