Issues with the Chrome extension
Incident Report for Interseller
Resolved
This issue has been resolved, thanks for your patience!
Posted 7 months ago. Oct 18, 2018 - 16:16 EDT
Identified
We've identified the issue and deploying a fix now.
Posted 7 months ago. Oct 18, 2018 - 15:27 EDT
Investigating
We're currently looking into issues pulling emails with our Chrome extension right now.
Posted 7 months ago. Oct 18, 2018 - 14:44 EDT
This incident affected: Chrome Extension.