Multiple Weekly Reports
Incident Report for Interseller
Resolved
This incident has been resolved.
Posted 27 days ago. Aug 19, 2019 - 13:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Aug 19, 2019 - 13:05 EDT
Identified
We've identified the issue and working on resolving it now. We are extremely sorry for the multiple emails you may have received from us!
Posted 27 days ago. Aug 19, 2019 - 12:57 EDT
Investigating
We're looking into issues with our weekly reports and multiples of them sending out.
Posted 27 days ago. Aug 19, 2019 - 12:48 EDT