Chrome Extension Issues
Incident Report for Interseller
Resolved
Our Chrome extension has been released to the Chrome Web Store. Please follow this article to ensure your Chrome extension is up-to-date: https://help.interseller.io/en/articles/2559963-keeping-the-chrome-extension-up-to-date
Posted Mar 04, 2020 - 23:24 EST
Update
We're continuing to wait for Google's team to release our new Chrome extension version. We're sorry for the inconvenience!
Posted Mar 04, 2020 - 08:15 EST
Identified
We've released a fix to the Chrome Web Store to help resolve issues with LinkedIn Sales Navigator. We are currently waiting for that release to reviewed by Google and will have updates when it's available.
Posted Mar 03, 2020 - 14:57 EST
This incident affected: Chrome Extension.