Email Verifications
Incident Report for Interseller
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 22, 2019 - 10:00 EDT
Update
We are continuing to monitor for any further issues.
Posted about 2 months ago. Mar 21, 2019 - 22:15 EDT
Update
We're sad to say that we'll be removing the "select all" button from our Chrome extension for all users. This isn't a decision we take lightly but have decided that the "select all" button promoted too much bad behavior (e.g. select and forget).

We also will be evaluating all of our customers' email sequences to ensure the highest level of quality possible. Please be on the lookout for an email from our team in the next couple of days. We will be working closely with each of you to build quality sequences.
Posted about 2 months ago. Mar 21, 2019 - 16:34 EDT
Update
We've also removed importing CSV files by names and company websites. This has been a feature that has been misused and accidentally used on numerous occasions.
Posted about 2 months ago. Mar 21, 2019 - 14:19 EDT
Update
As part of our efforts to reduce email validation problems, we will be enforcing 1 email per 60 seconds. This should help with deliverability across all customers and improve the experience for everyone. Interseller's stance has been and will always be to help our customers engage with their candidates and not send high-volume unsolicited email. If this affects your workflow, please reach out so we can help address changes. Furthermore, we will be implementing more changes to come.
Posted about 2 months ago. Mar 21, 2019 - 13:45 EDT
Update
Email sending is back to operational status but we'll continue monitoring for problems. Given this problem, we will need to enforce certain rules on our platform to prevent similar issues in the future. We will be announcing updates shortly.
Posted about 2 months ago. Mar 21, 2019 - 12:18 EDT
Monitoring
We've implemented a temporary fix to email validations. It'll take several hours for all systems to recover to normal. We are unfortunately working at a degraded state until we find a full solution to the problem. For the time being, emails should resume sending normally.
Posted about 2 months ago. Mar 20, 2019 - 19:57 EDT
Update
Our email verification engine is currently operating worse than expected. This is currently affecting work email lookups and email sending. Contacts that have been added within the past 24 hours may not send emails and cause the email queue to be delayed. We're working through potential resolutions at this time but do not know when we'll have a fix.
Posted about 2 months ago. Mar 20, 2019 - 17:44 EDT
Update
We're working on implementing alternative methods to validating email addresses at this time.
Posted about 2 months ago. Mar 20, 2019 - 15:58 EDT
Identified
We're currently having slower than normal issues with validating email addresses at this time. This will affect sending emails to newer contacts and Chrome extension lookups.
Posted about 2 months ago. Mar 20, 2019 - 15:03 EDT
This incident affected: Email Sending & Syncing and Chrome Extension.