G Suite Outage
Incident Report for Interseller
Resolved
Sync is up to speed and all Google services are running normally.
Posted 3 months ago. Jun 18, 2019 - 13:28 EDT
Monitoring
G Suite services are recovering. We are currently processing a large backlog at this time with all Google accounts. We'll continue monitoring the situation until service has been fully restored.
Posted 3 months ago. Jun 18, 2019 - 12:41 EDT
Identified
Email sending & syncing have been paused for Google accounts due to a widespread G Suite outage. We'll continue to monitor the situation.

https://www.google.com/appsstatus#hl=en&v=status
Posted 3 months ago. Jun 18, 2019 - 11:20 EDT
This incident affected: Email Sending & Syncing.