Search Degraded
Incident Report for Interseller
Resolved
This incident has been resolved.
Posted 6 days ago. Jul 09, 2019 - 17:36 EDT
Identified
We've identified the problem and are working on a fix.
Posted 6 days ago. Jul 09, 2019 - 17:25 EDT
Investigating
We're currently looking into issues with our contact search.
Posted 6 days ago. Jul 09, 2019 - 17:12 EDT
This incident affected: Website & API.